Excel 2007 20.09.2010, 12:58 Uhr

Listenvergleich per Format

Mit bedingten Formaten lassen sich in Excel 2007 Beziehungen zwischen Daten auf einfache Weise optisch hervorheben. Um beispielsweise Unterschiede zwischen zwei Wertespalten schnell zu finden, reichen Formeln, die bestimmen, in welcher Farbe der Zellhintergrund und die Schrift erscheinen.
Es vereinfacht die Sache, wenn Sie beide Wertebereiche zunächst über Formeln/Namen definieren benennen. Ist der erste Bereich ausgewählt, rufen Sie über Start/Bedingte Formatierung/Neue Regel den Dialog Neue Formatierungsregel auf. Unter Regeltyp auswählen wird die letzte Option benötigt, die die Eingabe einer Formel erlaubt. Die Formel
=ZÄHLENWENN(WertelisteB;A2)=0
prüft, ob der erste Wert in der Spalte in der Nachbarspalte nicht zu finden ist. Falls dies der Fall ist, soll die Zelle eine andere Hintergrund- und Textfarbe erhalten, was Sie über die Schaltfläche Formatieren festlegen. Für die zweite Spalte wird entsprechend die Formel
 =ZÄHLENWENN(WertelisteA;B2)=0
verwendet. Insbesondere, wenn es sich in beiden Spalten um eindeutige Werte handelt, die in der gleichen Weise sortiert sind, ist dieses Verfahren sehr effektiv (vergleiche Abbildung). Sie sehen sofort, welche Werte jeweils in der anderen Spalte fehlen oder zusätzlich vorkommen. Dabei spielt es keine Rolle, ob es sich um Zahlen oder Textwerte handelt. (Helmut Vonhoegen/am)




Das könnte Sie auch interessieren