Excel 2007 04.04.2011, 16:26 Uhr

Vorkommen zählen

In Excel wird die statistische Funktion HÄUFIGKEIT() verwendet, um zu ermitteln, wie oft ein bestimmter Wert in einem Zellbereich vorkommt. Als Argumente werden der Bereich mit den Daten und ein Bereich mit Klassengrenzen angegeben.
Die Funktion ist beispielsweise in der Lage, eine Gruppe von Personen nach bestimmten Alters- oder Einkommensstufen zu gruppieren. Die untere Abbildung zeigt eine Tabelle mit einer Spalte, in der Trefferquoten bei einem Spiel notiert sind. Im Bereich E4:E6 sind die Klassengrenzen eingetragen. Da die Funktion als Ergebnis eine Matrix liefert, ist zunächst ein entsprechender Bereich zu markieren, hier F4:F7. Der Bereich enthält eine Zelle mehr als der Bereich mit den Klassengrenzen, damit in der letzten Zelle die Anzahl der Werte angezeigt wird, die über der höchsten Klassengrenze liegen. Die einzugebende Formel für den Bereich der Häufigkeitsverteilung lautet:
{=HÄUFIGKEIT(B4:B23;E4:E6)}
Da es eine Matrixformel ist, muss sie mit [Strg]+[Umschalt]+[Enter] abgeschlossen werden. Was aber, wenn Sie einfach nur wissen sollen, wie häufig die einzelnen Werte einer Spalte darin vorkommen? Hier hilft die Funktion ZÄHLENWENN(). Die Formel in C4 lautet:
=ZÄHLENWENN($B4:$B24;B4)
Diese Formel wird per Doppelklick auf das Ausfüllkästchen bis zu C24 kopiert. Das erste Argument, der Bereich, der ausgewertet werden soll, wird mit absoluten Zelladressen angegeben, damit er beim Kopieren nicht verändert wird. Als zweites Argument – Suchkriterium – wird jeweils die Zelle mit der einzelnen Trefferquote angegeben. (Helmut Vonhoegen/am)
 




Das könnte Sie auch interessieren